MicroSD wifi card works but no signal.

ZhangJieJing kzjeef at gmail.com
Sat Nov 14 23:59:54 EST 2009


Hi wolfgang,

After last email about micro sd card wifi(shortly called wifi), I search a
lot want to find why sd command CMD53 (write or read block of buffer to
sdio), but still have no idea. But the log show CMD52 is Okey, but this
command only transfer one byte once. So, I change CMD53 to lots of CMD52 to
upload firmware to wifi card.

For now, the firmware can upload to the card(a little slow), I can see a
eth3 wireless interface in command iwconfig:
this is the output:

kzj at t61: wireless $ iwconfig eth3
eth3      IEEE 802.11b/g  ESSID:off/any  Nickname:""
          Mode:Managed  Frequency:2.457 GHz  Access Point: Not-Associated
          Bit Rate:11 Mb/s
          RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

from the log the wifi card print:
Nov 14 21:21:18 t61 kernel: [  541.042232] ks_wlan: MAC ADDRESS =
00:12:e6:50:00:de
Nov 14 21:21:18 t61 kernel: [  541.047766] ks_wlan: firmware ver. =
7010-SDIO-0.2f [Jun 04 2009  15:41:36]

I can see the firmware version number.

The problems are:

1)
the signal level of wifi card is 0,
 from iwconfig output:
Link Quality=0/100
and dmesg log:

Nov 14 21:22:54 t61 kernel: [  637.047362]     rssi=0
Nov 14 21:22:54 t61 kernel: [  637.047363]     signal=0
Nov 14 21:22:54 t61 kernel: [  637.047364]     LinkSpeed=22x500Kbps
Nov 14 21:22:54 t61 kernel: [  637.047364]     TransmittedFrameCount=0
Nov 14 21:22:54 t61 kernel: [  637.047365]     ReceivedFragmentCount=0
Nov 14 21:22:54 t61 kernel: [  637.047366]     FailedCount=0
Nov 14 21:22:54 t61 kernel: [  637.047366]     FCSErrorCount=0

So, I can't get any Access Point at all.

The log driver genrated is in [1], maybe the vendor can find the
problem.

2) the CMD52 only transfer one byte one time, and I can see the wifi card
use this CMD transfer IP package, Maybe fatal drop for performance. I can't
figure out this CMD53 failed is caused by my SD HOST Controller or the
MiroSD wifi card.

Any suggestion is grateful.


* Test envriment:
uname -a
Linux t61 2.6.28.9t6101 #1 SMP Fri Nov 13 22:37:29 CST 2009 i686 GNU/Linux
machine:
   Lenovo IBM ThinkPad T61 (SDIO controller: Ricoh)

and MiroSD wifi card with standard SD card Adapter.


[1]  http://downloads.qi-hardware.com/people/kzjeef/log.nosignal.tar.bz2
---
Best regards,
Zhang Jiejing
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.en.qi-hardware.com/pipermail/discussion/attachments/20091115/b72fc08a/attachment.htm>


More information about the discussion mailing list


interactive