alsa in the userspace

ZhangJieJing kzjeef at gmail.com
Thu Oct 15 00:31:02 EDT 2009


HI,

could you send the boot log of ALSA here?
after ALSA init,
it will print the sound card list.

Which kernel tree you are using?
---
Best regards,
Zhang Jiejing


On Thu, Oct 15, 2009 at 11:21 AM, Xiangfu Liu <xiangfu at qi-hardware.com>wrote:

> Andrés Calderón wrote:
> > Hi,
> >
> > I'm starting to try the alsa-utils, I have the following error with
> aplay:
> >
> >
> > root at xburst:/proc/asound# aplay -l
> > aplay: device_list:223: no soundcards found...
> >
> > Is this a error  in kernel or a setup error in the userspace?
> >
>
> I think it's in kernel. do you have this device  "/dev/dsp"
> Jiejing have enable the pavo sound driver in Ben, the info just like blow.
> but the sound not work.
>
> what rootfs you use?
>
> > Any recommendations?
> >
> > thanks in advance,
> >
> > Some debug data:
> >
> > uname -a
> > Linux xburst 2.6.24.3-gfa3de51a-dirty #49 PREEMPT Thu Oct 8 15:24:47 COT
> > 2009 mips unknown
> >
> >
> > in the kernel log:
> >
> > ALSA device list:
> >   #0: Pavo (JZCODEC)
> >
> > in the /proc file system
> > root at xburst:/proc/asound# tree
> > .
> > |-- Pavo -> card0
> > |-- card0
> > |   |-- id
> > |   |-- oss_mixer
> > |   |-- pcm0c
> > |   |   |-- info
> > |   |   |-- oss
> > |   |   `-- sub0
> > |   |       |-- hw_params
> > |   |       |-- info
> > |   |       |-- status
> > |   |       `-- sw_params
> > |   `-- pcm0p
> > |       |-- info
> > |       |-- oss
> > |       `-- sub0
> > |           |-- hw_params
> > |           |-- info
> > |           |-- status
> > |           `-- sw_params
> > |-- cards
> > |-- devices
> > |-- oss
> > |   |-- devices
> > |   `-- sndstat
> > |-- pcm
> > |-- timers
> > `-- version
> >
> > root at xburst:/proc/asound# cat cards
> >  0 [Pavo           ]: JZCODEC - Pavo
> >                       Pavo (JZCODEC)
> >
> > root at xburst:/proc/asound# cat devices
> >   0: [ 0]   : control
> >  16: [ 0- 0]: digital audio playback
> >  24: [ 0- 0]: digital audio capture
> >  33:        : timer
> > root at xburst:/proc/asound#
> > root at xburst:/proc/asound# cat pcm
> > 00-00: JZCODEC JZCODEC-I2S-0 :  : playback 1 : capture 1
> >
> > the .config
> > #
> > # Sound
> > #
> > CONFIG_SOUND=y
> >
> > #
> > # Advanced Linux Sound Architecture
> > #
> > CONFIG_SND=y
> > CONFIG_SND_TIMER=y
> > CONFIG_SND_PCM=y
> > # CONFIG_SND_SEQUENCER is not set
> > CONFIG_SND_OSSEMUL=y
> > CONFIG_SND_MIXER_OSS=y
> > CONFIG_SND_PCM_OSS=y
> > CONFIG_SND_PCM_OSS_PLUGINS=y
> > # CONFIG_SND_DYNAMIC_MINORS is not set
> > CONFIG_SND_SUPPORT_OLD_API=y
> > # CONFIG_SND_VERBOSE_PROCFS is not set
> > # CONFIG_SND_VERBOSE_PRINTK is not set
> > # CONFIG_SND_DEBUG is not set
> >
> > #
> > # Generic devices
> > #
> > # CONFIG_SND_DUMMY is not set
> > # CONFIG_SND_MTPAV is not set
> > # CONFIG_SND_SERIAL_U16550 is not set
> > # CONFIG_SND_MPU401 is not set
> >
> > #
> > # ALSA MIPS devices
> > #
> >
> > #
> > # System on Chip audio support
> > #
> > CONFIG_SND_SOC=y
> >
> > #
> > # SoC Audio support for SuperH
> > #
> > CONFIG_SND_JZ4740_SOC=y
> > CONFIG_SND_JZ4740_SOC_PAVO=y
> > # CONFIG_SND_JZ4740_AC97 is not set
> > CONFIG_SND_JZ4740_SOC_I2S=y
> > CONFIG_SND_SOC_ICODEC=y
> >
> > #
> > # Open Sound System
> > #
> > # CONFIG_SOUND_PRIME is not set
> >
>
> _______________________________________________
> Qi Developer Mailing List
> Mail to list (members only): developer at lists.qi-hardware.com
> Subscribe or Unsubscribe:
> http://lists.qi-hardware.com/cgi-bin/mailman/listinfo/developer
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.en.qi-hardware.com/pipermail/discussion/attachments/20091015/3dc098af/attachment.htm>


More information about the discussion mailing list


interactive