binary feed for qi packages

Kristoffer Ericson kristoffer.ericson at gmail.com
Sun Apr 11 06:31:48 EDT 2010


On Sun, 11 Apr 2010 11:51:48 +0200
marc zonzon <marc.zonzon at gmail.com> wrote:

> On Sun, Apr 11, 2010 at 10:45 AM, Kristoffer Ericson
> <kristoffer.ericson at gmail.com> wrote:
> 
> > I have a beta repository up on http://jlime.com/downloads/repository/muffinman/ipk/,
> > its not complete and about a month old, but covers about 250MB of binaries.
> >
> > --
> > Kristoffer Ericson <kristoffer.ericson at gmail.com>
> >
> 
> Thank you Kristoffer
> 
> I knew your repository with ipk from 2010-10-02. But what is missing
> is what package actually work, and with which kernel.

Without having tested every package, they should all work.
The issues one might encounter when using them together
with the standard userland is maybe with glibc and other libraries.
Not sure what version openwrt uses.
Kernel version is 2.6.32-hpc which essentially is same as openwrt 2.6.32 for nanonote.

> I tried Jlime on
> nano with your kernel and userspace and failed to boot, I also
> builded kernel with openembedded, but cannot achieve to make it boot
> the rootfs.
> 
Ive kept my development with sd-micro booting so maybe its broken
for nand booting? That said, school is doing a good job at keeping me busy
but will check it as soon as I can.

> And I don't know anything about the present stae of Jlime port, no
> info on Jlime site or forum.
The focus has early on been to create a solid repository, which was
on my part somewhat stupid since the kernel and userland should have
taken first priority.

> 
> May be you can tell a little more here. What is the state of the
> kernel did you apply the ingenic and qi-hardware patches in
> openembedded?
Ive kept linux-hpc.git branch v2.6.32-hpc updated with latest kernel patches
from openwrt. In openembedded Ive slowly created the different packages needed
for successful compilation, the kernel used is compiled from the v2.6.32-hpc branch.
Using openembedded it now runs from start to finish in building the initial userland.
The progression now is to adjust things we want inside the userland and the settings for
necessary packages.
> 
> In the ipkg repository you seem to use xorg have you had any success
> with it on Ben?
I see no reason why xorg shouldnt work on the nanonote. Havent tried it but
we got it on other devices.

> Do you use fpu in your binary?
Should be software fpu I believe.
> 
> Please tell us, and cross post on Jlime forum, it will be very usefull.
Im away during the coming week (clinical period in school), but will be back
after that and will then have time to update all the information on site (and also do testing).

Best wishes
Kristoffer

> 
> Marc


-- 
Kristoffer Ericson <kristoffer.ericson at gmail.com>




More information about the discussion mailing list


interactive