ALSA Question & Answer & sndpeek ported (console version)

Rubén Berenguel ruben at mostlymaths.net
Tue Apr 13 06:41:55 EDT 2010


Indeed, I'll do tonight is I can spare the time. I want to try my
compiled sndpeek to see if it can get something. Some idea on what use
could have a NanoNote with whistle control :D? Too big for a keychain,
though.

Thanks for your pointers!

On Tue, Apr 13, 2010 at 12:36, marc zonzon <marc.zonzon at gmail.com> wrote:
> On Thu, Apr 8, 2010 at 4:38 AM, Wolfgang Spraul <wolfgang at sharism.cc> wrote:
>> Ruben,
>>
>>> doesn't register any output. It may be my fault (I had to patch the
>>> main sndpeek.cpp to make it compile), but as sox's rec does not record
>>> anything, it may be not. Any hints?
>>
>> You are probably the first one to seriously look at the microphone, so
>> it's very possible that the problem is in the kernel or sound drivers.
>> AFAIK nobody has ever used the microphone under Linux until today.
>> If someone has, please speak up.
>>
>> What I can contribute to this right now is only to assert you that the
>> hardware is definitely OK. Luckily for us at this point, the entire
>> production process including production testing is happening with a
>> proprietary microkernel.
>> All functions of the device, including recording, playback, playing
>> videos and what not, are exhaustively tested on each Ben NanoNote.
>>
>> As a last step we flash our Linux image onto the device.
>> We knew that we couldn't get the completeness of the Linux image to the
>> point that it could be used for production verification. Now that we
>> have more and more eyes on the platform, we can fix all those bugs like
>> microphone support, and then at some point risk a production run that
>> uses Linux and 100% GPL software to verify that every device works.
>> But our image itself better be really bug-free and predictable before
>> we do that :-)
>>
>> I understand it's a bit scary to realize that we might have never
>> successfully used the microphone under Linux. We have to have some
>> faith in our ability to make it work now, knowing that there is
>> proprietary software that can do that as well...
>>
>> Can you write up the microphone problem in the issue tracker?
>> http://projects.qi-hardware.com/p/ben-nanonote/issues/
>>
>> Thanks for your feedback,
>> Wolfgang
>>
>> On Wed, Apr 07, 2010 at 09:46:33PM +0200, Rubén Berenguel wrote:
>>> Hi again,
>>>
>>> I already solved that problem (it was easy... my fault). I solved
>>> several more problems, and it looks like I have sndpeek (in console
>>> text mode, of course) ported to the Ben. The problem... Although I
>>> think I was hinted at the answer a few days ago: Does the mic work? I
>>> have raised its volume in alsamixer to the maximum, but sndpeek
>>> doesn't register any output. It may be my fault (I had to patch the
>>> main sndpeek.cpp to make it compile), but as sox's rec does not record
>>> anything, it may be not. Any hints?
>>>
>>> Thanks
>>>
>>> --
>>> ====================================
>>> * Rubén Berenguel
>>> * www.mostlymaths.net
>>> ====================================
>>
>
> I gave a try to Ben recording, I use the Ben official image from the
> 08-Apr-2010,
> I had n true problem for recording. The Mic control is turned off by
> default, I had to set it on with amixer, and augment the recording
> level. The settings are not preserved when powering off, so it comes
> again turned off. From ssh both amixer or alsamixer can control the
> card. But I could not achieve to turn on the control on from alsamixer
> on the Ben screen (no problem from ssh), probably a ncurses problem.
> For the mic level no problem. In any case amixer can change anything.
>
> I have not yet tested the quality of the recording. When I push the
> level too high, I just have a background beat, probably Ben's heart
> -):
>
> With sox recording in .snd is Ok yyu can pla back without problem. My
> sox is broken so I can record in .wav, but even if it is a correct wav
> sox does not recognize for playing, but you can play it with aplay.
>
> I would prefer to use arecord, but arecord is not in the provided
> package alsa-utils.
>
> I have also tried to test the compression options, alas we don't have
> a package with vorbis tools, no oggenc, but sox can encode in ogg but
> the encoding is too slow to be used in a pipe,
> for a 14s sample, I have a 29s encoding. My broken sox is also unable
> to read back the produced ogg file, it's nevertheless a valid file.
>
> The only option I found with sox for streaming the input is .gsm,
> transcoding my 14s sample in gsm is only 0.5s, a very small overhead
> when streaming and the compression rate is 0.1.
>
> I did not yet try to fiddle with the compression/quality rate in gsm
> or vorbis. This is only a short preliminary test.
>
> It would be nice to compile ogg-vorbis and speex encoders for the Ben.
> I hope that the 2011 YaNano will offer an external mic entry it will
> be very usefull.
>
> In any case I did not had the same problems that Rubén encountered.
> Rubén you might try again with the new kernel.
>
> Marc
>
> _______________________________________________
> discussion mailing list
> discussion at lists.qi-hardware.com
> http://en.qi-hardware.com/mailman/listinfo/discussion
>



-- 
====================================
* Rubén Berenguel
* Dep. de Mat. Aplicada i Anàlisi
Gran Via de les Corts Catalanes 585
08007 Barcelona, Spain
* http://www.maia.ub.es/~ruben
====================================




More information about the discussion mailing list


interactive