OpenWrt Image Release: 2010-12-14

David Kuehling dvdkhlng at gmx.de
Sun Dec 19 07:34:58 EST 2010


>>>>> "Niels" == Niels Felsted Thorsen <nift at maclisp.org> writes:

> I was pleased to see that emacs is now included! After a reflash I
> tried emacs right away, but the three first things I tried in emacs
> failed:

[..]

> C-x C-f /root/test.org "File mode specification error:
> (wrong-type-argument stringp (require . t-mouse))" and the file opens
> in Fundamental mode instead of the expected org-mode.

That's due to a strange entry in 'load-history' added by linux.el.  A
workaround is to enter:

(setq load-history
      (apply 'nconc (mapcar (lambda (v) (if (stringp (car v)) (list v) nil)) 
			    load-history)))

into site-start.el.  But that hack costs some 400k of memory, so I'll
search for a cleaner fix.

BTW the emacs package version you uses also suffers from a bug wrt
environment variables so .emacs might not load correctly (no $HOME).
Also with missing $PATH you might hit strange bugs.  Going to upload a
fixed version as soon as the 'make world' finishes.

cheers,

David
-- 
GnuPG public key: http://user.cs.tu-berlin.de/~dvdkhlng/dk.gpg
Fingerprint: B17A DC95 D293 657B 4205  D016 7DEF 5323 C174 7D40
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.en.qi-hardware.com/pipermail/discussion/attachments/20101219/7bf20d22/attachment.pgp>


More information about the discussion mailing list


interactive