Boot Error after flashing (Wrong Image Format for bootm command)

David Reyes Samblas Martinez david at
Wed Feb 24 04:45:08 EST 2010

Hi Klaus,
First for future use issues, like this one please use the discussion
list , I have added to cross posting, just to have things a little bit
in order. The discusion list has been just created so I understand you
post here, I'm just let you know :)

Then, to the point.
Have you erase the whole NAND before flashing?
Seems than  roll back to previous distro, or if you have also info
stored on NAND, cause some problems if not doin so, I guess because
information to flash is smaller , and the previous info on the NAND
remaining  mess the our little beast.

So here is the procedure to follow than has recovered my Ben from bricked state.

sudo usbboot -c "boot;nerase 0 4096 0 0"
sudo usbboot -c "nprog 0 openwrt-xburst-u-boot.bin 0 0 -n"
sudo usbboot -c "nprog 1024 openwrt-xburst-uImage.bin 0 0 -n"
sudo usbboot -c "nprog 2048 openwrt-xburst-rootfs.ubi 0 0 -n"

Please try and report back


2010/2/24 Klaus Fuerth <Klaus.Fuerth at>:
> Hello,
> after flashing my Ben NanoNote with 2010-01-13 Images my device don't boot
> the kernel anymore (I flashed that image earlier and it worked, md5sums are
> correct).
> I get the following messages on screen when powering up the device:
>> [...] many lines not seen on screen
>> Uncorrectable error occurred
>> Uncorrectable error occurred
>> Uncorrectable error occurred
>> Uncorrectable error occurred
>> Uncorrectable error occurred
>> Uncorrectable error occurred
>> Uncorrectable error occurred
>>   D read from offset ffffffff failed 41
>> 94304
>>  2097152 bytes read: ERROR
>>   kernel: default image load address =
>> 0x80600000
>> Wrong Image Format for bootm command
>> ERROR: can't get kernel image!
>> ERROR: can't get kernel image!
> I tried to reflash the device a few times, but the error is still there (see
> Flashing-Log). (it is very hard for me putting the device into usb-bootmode.
> Should PWR-U work with the 2010-01-13 bootloader? It does not for me, see
> below.)
> I think there are sectors marked as bad in the kernel section of flash?
> Could this cause the error?
> Is it possible to erase the flash (including bad sector list, maybe the
> sectors are ok)?
> Any suggestions?
> Thank you!
> Klaus
> PS:
> There is a small bug in '':
> l. 50: ">" should be ">>", otherwise the logfile gets purged after writing
> the date to it
> 'usbboot -c "boot" > "${LOG_FILE}" || abort "can't boot device -
> xburst-tools setup correctly? device in boot-mode? device connected?"'
> PPS:
> Error message after PWR-U and usbboot :> boot:
> usbboot - Ingenic XBurst USB Boot Utility
> (c) 2009 Ingenic Semiconductor Inc., Qi Hardware Inc., Xiangfu Liu, Marek
> Lindner
> This program is Free Software and comes with ABSOLUTELY NO WARRANTY.
> Now checking whether all configure args valid: YES
> Current device information:
> CPU type is Ingenic XBurst Jz4740
> Crystal work at 12MHz, the CCLK up to 252MHz and PMH_CLK up to 84MHz
> SDRAM Total size is 32 MB, work in 4 bank and 16 bit mode
> Nand page per block 128, Nand page size 4096, ECC offset in OOB 12, bad
> block offset in OOB 0, bad block page 127, use 1 plane mode
> usbboot :> boot
>  CPU data: JZ4740V1
>  CPU not yet booted, now booting...
>  Loading stage1 from '/usr/share/xburst-tools/xburst_stage1.bin'
>  Download stage 1 program and execute at 0x80002000
> Error - can't retrieve XBurst CPU information: -110
> usbboot :>
> _______________________________________________
> Qi Developer Mailing List
> Mail to list (members only): developer at
> Subscribe or Unsubscribe:

David Reyes Samblas Martinez
Open ultraportable & embedded solutions
Ben NanoNote, Arduino, Openmoko
Hey, watch out!!! There's a linux in your pocket!!!

More information about the discussion mailing list