Boot Error after flashing (Wrong Image Format for bootm command) -- SOLVED

David Reyes Samblas Martinez david at
Wed Feb 24 10:38:48 EST 2010

One more to the clean and clear build image procedure campaign :)
Klaus devels are now focused on the launch of the next release (audio
bug fixed+graphical interface+freecontents).
I guess when the can up his head from code and breath a little will
work on plain the way on building it from scratch.
If meanwhile someone comes with a procedure to build a working image
step by step will be greatly apreciated :P
Regards :)
2010/2/24 Klaus Fuerth <Klaus.Fuerth at>:
> Hi!
> on 2010-02-24 Lars-Peter Clausen wrote:
>> Hi
>> Could you try what David suggest while having set NAND_FORCEERASE=1 in
>> your /usr/local/etc/xburst-tools/usbboot.cfg
> Done. That solved my problem, the device boots again! :-) :-)
> Thank you all very much for helping me out and getting a working device
> again! :-)
> So what do you think cause this problem:
> * the sectors maked as bad in NAND (would be bad, because that could happen)
> or
> * the rest of my test-installation with wrong Images (formats, what ever)?
> I would like to build the openwrt-image again (and hopfully it will run next
> time) to add some ported software (maybe I begin from scatch downloading
> openwrt to be shure no errors are at my build environment).
> Looking forward to your next images....
> Klaus (very happy again with a working Ben ;-) )
> _______________________________________________
> Qi Developer Mailing List
> Mail to list (members only): developer at
> Subscribe or Unsubscribe:

David Reyes Samblas Martinez
Open ultraportable & embedded solutions
Ben NanoNote, Arduino, Openmoko
Hey, watch out!!! There's a linux in your pocket!!!

More information about the discussion mailing list