[U] + POWERON != working usbboot

Kristoffer Ericson kristoffer.ericson at gmail.com
Sat Jan 16 15:53:22 EST 2010


Greetings,

Well it wasnt bricked just being stubborn as always about
entering usbboot mode. Anyhow I reflashed with the latest bootloader supplied
by qi-hardware.com. It works fine, however Im still not able to do [U]+POWERON
and reflash.
It enters usbboot mode alright but when running usbboot -c "boot" I get
the same issue as I had earlier(see log below).
I thought it might be due to the stage1/2 files so I downloaded and compiled
xburst but getting same output. I earlier had updated the usbboot tool with same result.

I thought this was fixed? Or did I miss something?

For me personally (with major usbboot troubles) it would simplify my
life a great deal.

Best wishes
Kristoffer

usbboot - Ingenic XBurst USB Boot Utility
(c) 2009 Ingenic Semiconductor Inc., Qi Hardware Inc., Xiangfu Liu, Marek Lindner
This program is Free Software and comes with ABSOLUTELY NO WARRANTY.

Now checking whether all configure args valid: YES
Current device information:
CPU type is Ingenic XBurst Jz4740
Crystal work at 12MHz, the CCLK up to 252MHz and PMH_CLK up to 84MHz
SDRAM Total size is 32 MB, work in 4 bank and 16 bit mode
Nand page per block 128, Nand page size 4096, ECC offset in OOB 12, bad block offset in OOB 0, bad block page 127, use 1 plane mode
 Execute command: boot
 CPU data: JZ4740V1
 CPU not yet booted, now booting...
 Loading stage1 from '/usr/share/xburst-tools/xburst_stage1.bin'
 Download stage 1 program and execute at 0x80002000
Error - can't retrieve XBurst CPU information: -110
[root at boggieman xburst-tools_0.0+200906]#


-- 
Kristoffer Ericson <kristoffer.ericson at gmail.com>




More information about the discussion mailing list


interactive