Serial port and gps issues

cristian paul peñaranda rojas paul at kristianpaul.org
Fri Jul 9 22:21:16 EDT 2010


On Fri, Jul 09, 2010 at 05:17:12PM +0200, Bas Wijnen wrote:
> On Fri, Jul 09, 2010 at 09:50:54AM -0500, cristian paul peñaranda rojas wrote:
> >  GPS works just when the TX pin from it is wired to the Nanonote RX (i confirmed cause both picocom and gpsd show data coming from)
> > 
> >  But if RX is wired the tranmistion stoped :/, seems not be a power issue after tested with separate 3V3 power
> >  Is not gpsd, it also happen with picocom terminal.
> 
> I haven't tried receiving on my serial port yet, but AFAIK it shouldn't
> be a problem to do it simultaneously.
> 
> What I do know from serial ports in general, is that they can easily do
> strange things.  In this case, it sounds like there is data sent by the
> NanoNote, which confuses the gps.  Is it possible that the port is set
> to echo things which are sent to it, for example?  You can disable this
> with "stty -F /dev/ttyS0 -echo".
Thanks for sharing your wisdom now it dint stop seding data :)

I also aplied:
  

   stty speed 54600 </dev/ttyS0

In order to fix speed, gpsd still not foudingmy gps (SirF SIM548)
for the time of writing this mail, but i have one less issue to worry about :)


crstian paul


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.en.qi-hardware.com/pipermail/discussion/attachments/20100709/c37e0556/attachment.pgp>


More information about the discussion mailing list


interactive