U-Boot crashes when trying to boot microSD-card

David Kuehling dvdkhlng at gmx.de
Fri Jul 2 15:52:01 EDT 2010


Hi Xiangfu,

>>>>> "Xiangfu" == Xiangfu Liu <xiangfu at sharism.cc> writes:

> please test this u-boot[1] this u-boot: 1. change ENV size to 4K,
> 2. enable ECC check when nand read 3. when boot from mircoSD-card,
> read /uImage instead.  (this is workaround, I will keep work on this
> issue)

> so when you boot from sd. cp the /boot/uImage to /uImage.  DO not use
> "ln -s"

> give me some feedback thanks.  I tested with two 8GB sd card, format
> with 1 partition

> [1]http://downloads.qi-hardware.com/people/xiangfu/tmp/openwrt-xburst-qi_lb60-u-boot.2010.06.bin

Just flashed this version, and moved the uImage into the rootfs of my
4GB microSD card.

Now u-boot still crashes when trying to boot the sd card, but with a
different error message, see here:

  http://mosquito.dyndns.tv/david/nanonote/IMGP2569.JPG

  "ext2fs_devread() read outside partition sector -137631520"

Maybe it's time I make available an image file of the card?

thanks for your help so far,

cheers,

David
-- 
GnuPG public key: http://user.cs.tu-berlin.de/~dvdkhlng/dk.gpg
Fingerprint: B17A DC95 D293 657B 4205  D016 7DEF 5323 C174 7D40
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.en.qi-hardware.com/pipermail/discussion/attachments/20100702/703ebe92/attachment.pgp>


More information about the discussion mailing list


interactive