NanoMap 0.2

Xiangfu Liu xiangfu at
Sun Jul 11 11:35:37 EDT 2010

Hi Niels

I applied the patch. try to compile the NanoNote in openwrt
   make package/NanoMap/{clean,compile} V=99

It give me:
make[3]: /usr/bin/moc: Command not found[1]. but moc is at:

which file I should change to point to the right "moc". thanks.
(I make a symbol link at /usr/bin/moc. then nanomap compile fine.)

since the qt4.diff is not in svn://
so I mark the NanoMap as BROKEN for now. here[2] is the commit)


(cd /home/xiangfu/workspace/PanGu/openwrt-xburst/build_dir/target-mipsel_uClibc- && make)
make[4]: Entering directory `/home/xiangfu/workspace/PanGu/openwrt-xburst/build_dir/target-mipsel_uClibc-'
make[4]: Nothing to be done for `first'.
make[4]: Leaving directory `/home/xiangfu/workspace/PanGu/openwrt-xburst/build_dir/target-mipsel_uClibc-'
/usr/bin/moc -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../../staging_dir/target-mipsel_uClibc- -I. -I../../../staging_dir/target-mipsel_uClibc- -I../../../staging_dir/target-mipsel_uClibc- -I../../../staging_dir/target-mipsel_uClibc- -I../../../staging_dir/target-mipsel_uClibc- -I. mainwidget.h -o moc_mainwidget.cpp
make[3]: /usr/bin/moc: Command not found
make[3]: *** [moc_mainwidget.cpp] Error 127

On 07/11/2010 03:19 PM, Niels Kummerfeldt wrote:
> Am Sonntag, 11. Juli 2010, 04:25:39 schrieb Xiangfu Liu:
>> Hi Mark
>> I will try to work on NanoMap opkg package today or tomorrow.
>> then add it to openwrt-package.git
> Hi,
> some time ago I tried to make an OpenWrt Makefile but I had to change the qt4
> Makefile to get it working. The patch installs qmake and co into staging_dir
> and changes the mkspec file to set QMAKE_INCDIR_QT correctly. I don't know if
> this is the right way to go but it worked at that time.
> If you want to compile a qt4 program manually you just set PATH and QMAKESPEC.
> Something like this:
> #!/bin/sh
> basepath="/home/niels/Projekte/NanoNote/openwrt-xburst/"
> toolchainpath="staging_dir/toolchain-
> mipsel_gcc-4.3.3+cs_uClibc-"
> qtpath="staging_dir/target-mipsel_uClibc-"
> export PATH=$basepath$toolchainpath:$PATH
> export QMAKESPEC=$basepath$qtpath"usr/share/mkspecs/qws/linux-openwrt-g++"
> And then run:
> $ mkdir build
> $ cd build
> $ qmake ../
> $ make
> Hope this helps.
> Niels
> _______________________________________________
> discussion mailing list
> discussion at

Best Regards
Xiangfu Liu

More information about the discussion mailing list