Nanonote-Debian key map problem

Rubén Berenguel ruben at
Fri Jun 4 10:59:00 EDT 2010

I can't believe it. I changed /etc/console-tools/remap to well, remap
the problematic keys on boot time. I rebooted. Now it works... but I
only changed Q and ALL letters are now okay. The disturbing part is
that I found the problem with the keys yesterday night, and I did shut
down the nano during the night. And this morning it didn't work at all
(I mean, the keyboard problems, the nano works OK).

Loadkeys does only take effect on reboot, maybe?


2010/6/4 Rubén Berenguel <ruben at>:
> Marc,
> I did not change my keymap (as far as I know...), but did try to, when
> I saw the dumpkeys result. Loadkeys just won't load keys, after doing
> dumpkey > keys and solving "keys" problems, loadkeys keys results in
> the same dumpkeys. I.e. it is not changing at all.
> I looked for that file, but there are only a few .*map* files, mostly
> under emacs, the rest in console-tools, but not loaded :/
> Xiangfu,
> does this mean that the problem can't be solved as my nano stands? I
> can't write R...?
> Ruben
> On Fri, Jun 4, 2010 at 16:07, Xiangfu Liu <xiangfu at> wrote:
>> Hi
>> yes in OpenWrt we change the kernel file.
>> map the AltGr to [RED UP Arrow], CtrlL to [Blue Fn].
>> we can try to remove the 500[1] patch when compile Debian kernel.
>> then modify the keymap in Debian userspace.
>> [1]
>>  On 06/04/2010 08:15 PM, marc zonzon wrote:
>>> I think I see what happened, you changed your keymap. For BNN as their
>>> is no proper keymap in console package you have to rely on the Kernel
>>> Keymap, I now remember I had the same phenomena than you after trying
>>> to test different keymaps, even dpkg-reconfigure console-data, let me
>>> with a broken Keymap.
>> --
>> Best Regards
>> Xiangfu Liu
>> _______________________________________________
>> discussion mailing list
>> discussion at

More information about the discussion mailing list