Nanonote not charging (more or less) when on

Rubén Berenguel ruben at mostlymaths.net
Mon Jun 7 16:50:48 EDT 2010


I have been tinkering with hibernate and related processes... and I am
not sure if I messed something up (I have removed all packages I
installed this afternoon, but it is still the same).

The problem: The nano does not charge when powered on.

cat /sys/class/power_supply/battery/capacity changes veeeery slowly,
towards being charged, but at a rate which roughly looks like 1/20 or
more when it is powered off.

My memory is not that good, but I think it was faster, usually. And
didn't oscillate (now it is at 65, and oscillates to 66, i.e. repeated
cat shows 65 65 65 65 65 66 65 65 65 65 65 65 and so on. But if I
leave it off for just a few seconds, it will be charged more than a
2%.

Do you know what may be happening? The cpu is at 3.8% use (coming
mostly from htop, at 3%) On the other hand, hibernate did work as
expected, I guess.. hibernate did something which stopped the system,
and rebooted it on keypress. But when I wanted to check power usage,
it said 35%. As I had charged overnight, and I had left it untouched
all day (but powered on), I guess that the problem came with the first
things I did when connecting it to the power source.

I formatted my microSD card (ext2) with the nanonote, as I don't have
a microSD reader I can use. I set up a temporary swap file on it to
check for crawl (the roguelike I talked about a few days ago). It
works (through fbterm only) and then tried to install uswsusp, but it
is not in the sid repository, then installed hibernate... tinkered, as
it didn't seem to work, installed the linux-patch-tuxonice via
apt-get, but it needs to recompile the kernel, thus I removed it. Then
I checked again hibernate, and the nano powered off, and the history
started.

Now the nano is oscillating between 67 and 68. Maybe it is a bad case
of really slow charge speed? Is it normal!?

Ruben

-- 
====================================
* Rubén Berenguel
* http://www.mostlymaths.net
====================================




More information about the discussion mailing list


interactive