reflash_ben.sh problems

Xiangfu Liu xiangfu at sharism.cc
Sat Mar 27 07:33:24 EDT 2010


Hi Georg

very thanks the info. it's give me some tips.
I just update the "reflash_ben.sh"
we should first erase rootfs then flash the bootload, kernel and rootfs.

can you test current "reflash_ben.sh". give some feedback.
thanks

xiangfu

On 03/27/2010 05:07 PM, Georg Sassen wrote:
> Hi,
>
> I got my new Ben NanoNote this week, and now I'd like to flash the
> latest software onto it, so I downloaded reflash_ben.sh and xburst
> tools and just start reflash.sh without arguments while connected to
> the Ben in USB mode, so it downloads the latest bootloader, kernel and
> rootfs and flashes them afterwards.
>
> After some time it says it's ready. Then I pull of the USB cable and
> the battery, put the battery back in and try to switch it on - but the
> Ben won't switch on, the display keeps dark, and if I connect the cable
> and try lsusb on the PC, it doesn't see it.
>
> I tried this on an X86_64 machine with Ubuntu 9.10 and an x86 notebook,
> also with Ubuntu 9.10, same effect, Ben is directly connected to the
> USB port, no hub involved.
>
> I tried versions 2010-03-22, 2010-03-20 and just now tried out
> 2010-03-26 (which is latest since yesterday), same effect.
>
> But: When I put the NanoNote in USB bootmode now by shortening the pins
> on the back and try "reflash_ben.sh -bk", flashing only the kernel and
> bootloader, it will work afterwards.
>
> So it seems that the bootloader and/or kernel is overwritten by the
> rootfs flash - might I have a bad or too small flash? How can I test
> this? Or do I do it wrong?
>
> I copied the logfile of the full flash to
> http://aceite.sassen.de/log.txt.full.bz2 if you want to look at it.
>
>    Georg
>
>
>
>
> _______________________________________________
> discussion mailing list
> discussion at lists.qi-hardware.com
> http://en.qi-hardware.com/mailman/listinfo/discussion





More information about the discussion mailing list


interactive