/etc/init.d/fstab - is it necessary?

mark adrian bell m487396 at rocketmail.com
Wed Mar 31 19:07:47 EDT 2010


Following on from my investigations into why the sdcard doesn't automatically mount at boot, here is the end of my dmseg file:

[   10.650000] VFS: Mounted root (ubifs filesystem) on device 0:10.
[   10.670000] Freeing unused kernel memory: 204k freed
[   10.680000] mmc0: host does not support reading read-only switch. assuming write-enable.
[   10.690000] Please be patient, while OpenWrt loads ...
[   10.700000] mmc0: new SDHC card at address ff8b
[   10.720000] mmcblk0: mmc0:ff8b SU04G 3.69 GiB
[   10.740000]  mmcblk0: p1
[   19.260000] ks7010_sdio : Mar 25 2010 21:36:44
[   20.390000] tun: Universal TUN/TAP device driver, 1.6
[   20.400000] tun: (C) 1999-2004 Max Krasnyansky <maxk at qualcomm.com>
[   20.660000] No device for DAI jz4740-i2s
[   20.830000] asoc: jz-codec <-> jz4740-i2s mapping ok

I'm afraid I don't know what any of this stuff means. :-)

- mark



--- On Thu, 1/4/10, mark adrian bell <m487396 at rocketmail.com> wrote:

> From: mark adrian bell <m487396 at rocketmail.com>
> Subject: Re: /etc/init.d/fstab - is it necessary?
> To: "support  findings  use cases and funUsers mailinglist" <discussion at lists.qi-hardware.com>
> Received: Thursday, 1 April, 2010, 8:43 AM
> --- On Thu, 1/4/10, jirka <jirka at penguin.cz>
> wrote:
>
> > Why there is no /etc/init.d/fstab file? Is it not
> > necessary for the Ben? (it looks like /card is not
> > mounted by default?)
> >
> > I have the latest rootfs (flashed before few minutes)
>
> I'm puzzled by this too.
>
> OpenWRT uses a configuration utility called UCI
> http://wiki.openwrt.org/doc/uci
>
> Following http://wiki.openwrt.org/doc/uci/fstab
>
> I setup my /etc/config/fstab to look like this:
>
> config global automount
>     option from_fstab 1
>     option anon_mount 1
>
> config mount
>     option target   /card
>     option
> device   /dev/mmcblk0p1
>     option fstype   auto
>     option options  rw,sync
>     option enabled  1
>
> and ran 'uci fstab commit' and rebooted.
>
> But alas, my card has not been auto mounted. 'uci show
> fstab' gives:
>
> ~# uci show fstab
> fstab.automount=global
> fstab.automount.from_fstab=1
> fstab.automount.anon_mount=1
> fstab. at mount[0]=mount
> fstab. at mount[0].target=/card
> fstab. at mount[0].device=/dev/mmcblk0p1
> fstab. at mount[0].fstype=auto
> fstab. at mount[0].options=rw,sync
> fstab. at mount[0].enabled=1
>
> What's really curious is that I can 'find' a '/etc/fstab'
> file, but I can't 'ls' or 'cat' it.
>
> ~# cd /etc
> /etc# find -name fstab
> ./fstab
> ./config/fstab
> /etc# ls fstab
> ls: fstab: No such file or directory
> /etc# cat fstab
> cat: can't open 'fstab': No such file or directory
> /etc#
>
> Could this be something to do with having the right kernel
> modules available at boot?
>
> - mark
> 



      




More information about the discussion mailing list


interactive