gNewSense on the NanoNote?

Xiangfu Liu xiangfu at sharism.cc
Tue Nov 23 20:41:46 EST 2010


On 11/24/2010 02:14 AM, Niels Serup wrote:
> Today I succesfully compiled a linux-libre kernel that worked on my
> NanoNote Debian installation. I then tried to create a gNewSense image
> (so that I could run that instead of Debian), but I failed. Using a
> combination of debootstrap and chroot, I did manage to create a minimal
> installation of gNewSense longsoon (mipsel, of course) on my microSD
> card (first partition), but when I booted from it, it erred:
> 
> Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(179,1)
> 
> The Debian image from pyneo.org works just fine for me, both on my
> microSD card and on the NAND (where I usually run it). If I knew how the
> image from pyneo.org was created (I guess it's pretty much the same as
> what I did, just with a twist) I could probably easily create the
> gNewSense image I want. Does anyone know how to create such a rootfs
> that can be run on both microSD cards and NAND memory?

checkout : http://en.qi-hardware.com/wiki/Ubifs

run on microSD and NAND are same files. only one is tar.gz, another one is .ubi

> 
> 
> These are the commands I used to debootstrap gnewsense:
> 
> On my desktop computer:
> 
> sudo debootstrap --arch=mipsel --foreign metad gnsdir/ \
> http://archive.gnewsense.org/gnewsense-metad/gnewsense/
> 
> On my NanoNote:
> 
> chroot /mnt/card
> ./debootstrap/debootstrap --second-stage
> cd etc && ln -s ../sbin/init ./preinit
> 
> -----
> Niels
> 
> 
> _______________________________________________
> Qi Hardware Discussion List
> Mail to list (members only): discussion at lists.en.qi-hardware.com
> Subscribe or Unsubscribe: http://lists.en.qi-hardware.com/mailman/listinfo/discussion


-- 
Best Regards
Xiangfu
-- Qi RSS feed, http://en.qi-hardware.com/feed/rss20.xml --




More information about the discussion mailing list


interactive