reflash_ben.sh

Yi Zhang yi at sharism.cc
Thu Nov 25 04:48:45 EST 2010


Hi Xiangfu,

One thing I forgot to mention. After I commented out the block which getting
.ubi.bz2 rootfs file (see below), everything worked out fine.

----------------------------------
        if [ "$R" == "TRUE" ]; then
#               log "try fetching .ubi.bz2 rootfs..."
#               wget \
#                   -a "${LOG_FILE}" \
#                   -P "${WORKING_DIR}" \
#                   "${BASE_URL_HTTP}/${VERSION}/${ROOTFS}.bz2" && \
#                   (cd ${WORKING_DIR}; bzip2 -d ${ROOTFS}.bz2)

#               if [ "$?" == "8" ]; then
                    log "fetching .ubi rootfs..."
                    wget \
                        -a "${LOG_FILE}" \
                        -P "${WORKING_DIR}" \
                        "${BASE_URL_HTTP}/${VERSION}/${ROOTFS}"
#               fi
----------------------------

Hope this helps.

Yi

On Thu, Nov 25, 2010 at 5:00 PM, Yi Zhang <yi at sharism.cc> wrote:

> Hi Xiangfu,
>
> What you can try is to first delete all files
> openwrt-xburst-qi_lb60-u-boot.bin, openwrt-xburst-qi_lb60-uImage.bin, and
> openwrt-xburst-qi_lb60-root.ubi from your ${HOME}/.qi/nanonote/ben/latest
> folder. Then run reflash_ben.sh. Make sure you get the reflash_ben.sh from
> [1]. You may see the problem right away. Meanwhile let me send you the log
> file and output messages privately.
>
> Thanks,
> Yi
>
> [1]
> http://downloads.qi-hardware.com/software/images/NanoNote/Ben/reflash_ben.sh
>
>
> On 2010-11-25, at 上午9:43, Xiangfu Liu wrote:
>
>  Hi Yi
>>
>> please send the "~/.qi/nanonote/ben/latest/log.txt" and all output
>> messages to me.
>> I just double check this file, it works fine here.
>>
>> On 11/25/2010 04:26 AM, Yi Zhang wrote:
>>
>>> Hi Xiangfu,
>>>
>>> I have tried reflash the latest image by following simple steps at [1].
>>> Then I got the error message "can't find file
>>> openwrt-xburst-qi_lb60-root.ubi...". I realized the following scripts didn't
>>> run correctly:
>>>
>>> ------------------------------------------
>>>
>>>    if [ "$R" == "TRUE" ]; then
>>>        log "try fetching .ubi.bz2 rootfs..."
>>>        wget \
>>>            -a "${LOG_FILE}" \
>>>            -P "${WORKING_DIR}" \
>>>            "${BASE_URL_HTTP}/${VERSION}/${ROOTFS}.bz2" && \
>>>            (cd ${WORKING_DIR}; bzip2 -d ${ROOTFS}.bz2)
>>>
>>>        if [ "$?" == "8" ]; then
>>>            log "fetching .ubi rootfs..."
>>>            wget \
>>>            -a "${LOG_FILE}" \
>>>            -P "${WORKING_DIR}" \
>>>            "${BASE_URL_HTTP}/${VERSION}/${ROOTFS}"
>>>        fi
>>>    fi
>>>
>>> ------------------------------
>>>
>>> What I understood is, if it didn't find file {ROOTFS}.bz2, it should go
>>> on fetching {ROOTFS} file, but in reality, it didn't do so, instead it went
>>> straight to the next step: "booting device..."
>>>
>>> Could you please take a quick look at it?
>>>
>>> Thanks,
>>> Yi
>>>
>>> [1] http://en.qi-hardware.com/wiki/Reflash_ben.sh
>>>
>>> _______________________________________________
>>> Qi Hardware Discussion List
>>> Mail to list (members only): discussion at lists.en.qi-hardware.com
>>> Subscribe or Unsubscribe:
>>> http://lists.en.qi-hardware.com/mailman/listinfo/discussion
>>>
>>
>>
>> --
>> Best Regards
>> Xiangfu
>> -- Qi RSS feed, http://en.qi-hardware.com/feed/rss20.xml --
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.en.qi-hardware.com/pipermail/discussion/attachments/20101125/0e4fb877/attachment.htm>


More information about the discussion mailing list


interactive