Gnuplot?

Xiangfu Liu xiangfu at sharism.cc
Wed Oct 27 22:08:53 EDT 2010


Hi Ruben

On 10/27/2010 11:46 PM, Rubén Berenguel wrote:
> I am seeing lately a lot of activity in the Ben world, which sadly I
> can barely keep up with. I have a pair of questions / enquiries, that
> maybe have been solved while I was looking at other things.
> 
> Is there a way to have gnuplot in jlime/openwrt?

the gnuplot already ported to openwrt:
Search results in feed 'packages':
gnuplot                  	A portable command-line driven graphing utility

but I got an error when compile gnuplot in openwrt. :( [1]

> 
> Is there a way to display images correctly if using Debian?
> 
> I tried a while ago, and the results were less than perfect. The image
> viewer I used to display images generated by gnuplot crashed every
> time I tried to do zoom ins or zoom outs.
> 
> Why I want gnuplot? Well, in Debian you can have together:
> 
> Yacas
> pari-gp
> gnuplot
> a taylor integration package from my research group
> gcc
> emacs
> 
> Which all together turn the ben into probably the best portable
> general purpose calculator out there. The problem, is that image
> thing. If not, it would be absolutely perfect!
> 
> Cheers,
> 
> Ruben
> 


[1]
inal/wxt_gui.cpp' || echo './'`wxterminal/wxt_gui.cpp
cc1plus: warning: include location "/usr/include/wx-2.8" is unsafe for cross-compilation
In file included from /usr/include/wx-2.8/wx/memory.h:16,
                 from /usr/include/wx-2.8/wx/object.h:20,
                 from /usr/include/wx-2.8/wx/wx.h:16,
                 from wxterminal/wxt_gui.h:77,
                 from wxterminal/wxt_gui.cpp:96:
/usr/include/wx-2.8/wx/string.h:827: error: 'wxChar& wxString::operator[](unsigned int)' cannot be overloaded
/usr/include/wx-2.8/wx/string.h:824: error: with 'wxChar& wxString::operator[](size_t)'
wxterminal/wxt_gui.cpp: In function 'void wxt_init()':
wxterminal/wxt_gui.cpp:1479: error: 'dynamic_cast' not permitted with -fno-rtti
wxterminal/wxt_gui.cpp: In function 'void wxt_atexit()':
wxterminal/wxt_gui.cpp:3177: error: 'dynamic_cast' not permitted with -fno-rtti
make[6]: *** [wxt_gui.o] Error 1
make[6]: Leaving directory `/home/xiangfu/openwrt-xburst.full_system/build_dir/target-mipsel_uClibc-0.9.32/gnuplot-4.4.0/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/xiangfu/openwrt-xburst.full_system/build_dir/target-mipsel_uClibc-0.9.32/gnuplot-4.4.0/src'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/xiangfu/openwrt-xburst.full_system/build_dir/target-mipsel_uClibc-0.9.32/gnuplot-4.4.0'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/xiangfu/openwrt-xburst.full_system/build_dir/target-mipsel_uClibc-0.9.32/gnuplot-4.4.0'
make[2]: *** [/home/xiangfu/openwrt-xburst.full_system/build_dir/target-mipsel_uClibc-0.9.32/gnuplot-4.4.0/.built] Error 2
make[2]: Leaving directory `/home/xiangfu/openwrt-xburst.full_system/feeds/packages/utils/gnuplot'
make[1]: *** [package/feeds/packages/gnuplot/compile] Error 2
make[1]: Leaving directory `/home/xiangfu/openwrt-xburst.full_system'
make: *** [package/gnuplot/compile] Error 2


-- 
Best Regards
Xiangfu
-- Qi RSS feed, http://en.qi-hardware.com/feed/rss20.xml --
-- Buy NanoNote http://www.nanonote.cc --




More information about the discussion mailing list


interactive