setfont2 on Debian

Xiangfu Liu xiangfu at sharism.cc
Thu Sep 23 06:43:40 EDT 2010


Hi Mark

I have tried "setfont2" in Debian rootfs this morning. 
(sorry for late reply. I forget send out the email :)

the setfont2 need two part.

1. the kernel patch.
2. the command "setfont2" and the font file.

this kernel[1] include the setfont2 patch. I have try 
this kernel with Debian rootfs. it works fine.

then I try to scp the "setfont2" to NanoNote.

1. scpben build_dir/target-mipsel_uClibc-0.9.32/setfont2-20100720/ 

2. then it give me a strange error:
 root@(none):~/setfont2-20100720# ./setfont2 fonts/un-fuzzy-6x10-font.pnm 
-bash: ./setfont2: No such file or directory
(I can sure the "setfont2" is right there)


3. I decide compile the "setfont2" inside Debian.
 apt-get install gcc build-essential

4. 
root@(none):~/setfont2-20100720# gcc setfont2.c 
root@(none):~/setfont2-20100720# ls
Makefile  a.out  fonts	setfont2.c
root@(none):~/setfont2-20100720# ./a.out
Use: ./a.out path-to-glyph-sheet.pnm
root@(none):~/setfont2-20100720# ./a.out fonts/un-fuzzy-6x10-font.pnm 

5. then we got the setfont2 in Debian rootfs

[1]http://downloads.qi-hardware.com/software/images/NanoNote/Ben/testing/2010-09-14/openwrt-xburst-qi_lb60-uImage.bin

On 09/23/2010 03:59 AM, Mark Tuson wrote:
> Hi everyone. I just wanted to ask if there's a new kernel out that'll run setfont2... is there? I tried the one that I was pointed to last, but it just showed me an OpenWRT bootscreen and hanged itself. Has anyone built it and successfully run it on Debian? I'd not ask this, but I tried on two different computers to get it all to build on my machine, and it refused on both.
> 
> I just want the 80x30-line display!
> 
> Thanks. Mark.
> 
> _______________________________________________
> Qi Hardware Discussion List
> Mail to list (members only): discussion at lists.en.qi-hardware.com
> Subscribe or Unsubscribe: http://lists.en.qi-hardware.com/mailman/listinfo/discussion


-- 
Best Regards
Xiangfu Liu
http://www.nanonote.cc




More information about the discussion mailing list


interactive