Problem running OpenWrt from SD card

Andrea Bolognani eof at kiyuko.org
Sat Aug 27 12:51:18 EDT 2011


Hi,

I’m trying to run the latest OpenWrt image from SD card in order to
try out some stuff without wearing out the NAND too much.

I’ve followed the instructions found on the wiki[1] and restarted my
Ben while pressing the M key: the kernel loads fine from SD, but after
a couple of seconds the following error message is displayed and the
system hangs:

	Kernel panic - not syncing: Attempted to kill init

I tried using the uImage on the SD card to boot the software image on
NAND and it works fine, while doing the opposite (kernel from NAND, rootfs
on SD) panics as well, so I guess the problem lies somewhere in the
compressed rootfs?

I’m currently compiling a minimal rootfs to test SD boot out; while I
wait for it to finish, has anybody encountered the same error before?


[1] http://en.qi-hardware.com/wiki/Updating_Ben_with_an_SD
-- 
Andrea Bolognani <eof at kiyuko.org>
Resistance is futile, you will be garbage collected.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.en.qi-hardware.com/pipermail/discussion/attachments/20110827/77894b17/attachment.pgp>


More information about the discussion mailing list


interactive