Problem running OpenWrt from SD card

Alan Post alanpost at sunflowerriver.org
Sat Aug 27 14:26:55 EDT 2011


I have encountered this.  It is preventing me from flashing my
NanoNote, actually.  I assumed I'd done something wrong.

For a variety of reasons I need to boot from an SD card to flash
my NanoNote, this procedure worked for me last time.  I haven't
come to being able to effectively debug this one yet.

Any clues at all would be an enormous help for me.  I've got two
NanoNotes sitting on my desk waiting to be flashed and one friend
who is far too patient with me. 

-Alan

On Sat, Aug 27, 2011 at 06:51:18PM +0200, Andrea Bolognani wrote:
> Hi,
> 
> I’m trying to run the latest OpenWrt image from SD card in order to
> try out some stuff without wearing out the NAND too much.
> 
> I’ve followed the instructions found on the wiki[1] and restarted my
> Ben while pressing the M key: the kernel loads fine from SD, but after
> a couple of seconds the following error message is displayed and the
> system hangs:
> 
> 	Kernel panic - not syncing: Attempted to kill init
> 
> I tried using the uImage on the SD card to boot the software image on
> NAND and it works fine, while doing the opposite (kernel from NAND, rootfs
> on SD) panics as well, so I guess the problem lies somewhere in the
> compressed rootfs?
> 
> I’m currently compiling a minimal rootfs to test SD boot out; while I
> wait for it to finish, has anybody encountered the same error before?
> 
> 
> [1] http://en.qi-hardware.com/wiki/Updating_Ben_with_an_SD
> -- 
> Andrea Bolognani <eof at kiyuko.org>
> Resistance is futile, you will be garbage collected.



> _______________________________________________
> Qi Hardware Discussion List
> Mail to list (members only): discussion at lists.en.qi-hardware.com
> Subscribe or Unsubscribe: http://lists.en.qi-hardware.com/mailman/listinfo/discussion

-- 
.i ma'a lo bradi cu penmi gi'e du




More information about the discussion mailing list


interactive