pm-suspend in Debian Nanonote

Rubén Berenguel ruben at mostlymaths.net
Tue Feb 15 04:27:54 EST 2011


Hi everyone,

a few days ago I dist-upgraded my Debian Sid, and out of curiosity
installed the pm-tools package. Last time I tried they did nothing, no
suspend enabled modes were available.

To my surprise, pm-suspend worked. It put to sleep my nano (with some
kernel messages going like "task freezing"... and when I pressed a key
it would wake up nicely. Some times when I put it to sleep the screen
turns brighlty white, starting to be brighter in the center and slowly
spreading.

The problem is, that after 45-50 seconds of pm-suspend (i.e. the nano
is sleeping), it just won't wake up. It looks as if it just was
halted. Any idea what is going on? Of course, there is no logging
after pm-suspend, and the pm-logs look correct (after removing some
scripts).

I'd love to have suspend in my nano. It has an awesome battery life,
but I want a little more... and quick response like this can make it
to be a very nice thought recording system (just like a tape
recorder).

Cheers,

Ruben

-- 
========================================
* Rubén Berenguel
* Homepage: http://www.mostlymaths.net
* RSS feed:   http://feeds.feedburner.com/MostlyMaths
* Twitter:       http://twitter.com/#!/berenguel
========================================




More information about the discussion mailing list


interactive