Sound issues

EdorFaus edorfaus at
Tue Sep 20 09:40:09 EDT 2011

On 08/23/2011 07:55 AM, Xiangfu Liu wrote:
> I have to revert the commit on asound.conf it make mic not working:
> <xiangfu> I do get some error when: arecord c.wav
> <xiangfu> ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin
> supports only playback stream
> <xiangfu> arecord: main:660: audio open error: Invalid argument

Ah, yes - I only did the playback part because I don't really use the 
mic myself, so didn't think to test that.

I've modified the config a bit so recording also works - in fact, I can 
now both playback and record multiple times simultaneously. :)

(I played around with this a bit, as I found that with the right volume 
settings, arecord|aplay keeps about the same volume for some things, so 
then I could use another window to record and replay parts of it. :) )

> found without the asound.conf the software volume control still works fine.

Hm, sort of - for me, the control still shows up in alsamixer (probably 
due to it having state in ALSA, since it's still there after a reboot 
unless I remove the .state file), but it isn't actually used by newly 
started programs - their volume is not affected by it. At least for me.

Another thing I found while testing the above, is that after I run aplay 
(playing a file recorded with arecord), nano (the editor) stops working 
- when started, it immediately exits after printing the message 
"Received SIGHUP or SIGTERM".

It starts working again if I log out and then back in (this is via ssh), 
or if I run bash and then exit it, so it's easily worked around -  but 
still odd.

I'm still on the same OS image as last time, though (haven't gotten 
around to upgrading yet, should do that soon), so for all I know this 
might have been fixed already...


P.S. As you might have understood from the above, I tend to use the 
"nano" editor - so keeping my notes on this thing is a bit punny, since 
I then run "nano notes" on my NanoNote. ;)
-------------- next part --------------
pcm.!default {
	type plug
	slave.pcm "asym"
pcm.asym {
	type asym
	playback.pcm "softvol"
	capture.pcm "dsnoop"
pcm.softvol {
	type softvol
	slave.pcm "dmix"
	control {
		name	"PCM"
		card	0
		count	1
# For OSS emulation
pcm.dsp0 {
	type plug
	slave.pcm "asym"
ctl.mixer0 {
	type hw
	card 0

More information about the discussion mailing list