fixed mplayer package

kyak bas at bmail.ru
Sun Apr 8 02:31:12 EDT 2012


Hi David,

root at ben:~# md5sum /usr/bin/mplayer
fc5dcf98310dfa4e52b9f051f36adbdb  /usr/bin/mplayer
root at ben:~# ldd /usr/bin/mplayer
ldd: can't open cache '/etc/ld.so.cache'
 	libiconv.so.2 => /usr/lib/libiconv.so.2 (0x779b5000)
 	libncurses.so.5 => /usr/lib/libncurses.so.5 (0x77979000)
 	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x77946000)
 	libz.so.1 => /usr/lib/libz.so.1 (0x77924000)
 	libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x778f5000)
 	libgif.so.4 => /usr/lib/libgif.so.4 (0x778de000)
 	libasound.so.2 => /usr/lib/libasound.so.2 (0x77800000)
 	libdl.so.0 => /lib/libdl.so.0 (0x777ec000)
 	libfribidi.so.0 => /usr/lib/libfribidi.so.0 (0x777ce000)
 	libtheora.so.0 => /usr/lib/libtheora.so.0 (0x77776000)
 	libogg.so.0 => /usr/lib/libogg.so.0 (0x77761000)
 	libm.so.0 => /lib/libm.so.0 (0x7773c000)
 	libdirectfb-1.4.so.0 => /usr/lib/libdirectfb-1.4.so.0 (0x776b6000)
 	libggi.so.2 => /usr/lib/libggi.so.2 (0x77621000)
 	libaa.so.1 => /usr/lib/libaa.so.1 (0x775fd000)
 	libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0x7758a000)
 	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x7756a000)
 	libc.so.0 => /lib/libc.so.0 (0x774c5000)
 	libX11.so.6 => not found
 	libpthread.so.0 => /lib/libpthread.so.0 (0x7749f000)
 	librt.so.0 => /lib/librt.so.0 (0x7748b000)
 	ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0x779cc000)
 	libfusion-1.4.so.0 => /usr/lib/libfusion-1.4.so.0 (0x77473000)
 	libdirect-1.4.so.0 => /usr/lib/libdirect-1.4.so.0 (0x77454000)
 	libvga.so => /usr/lib/libvga.so (0x77422000)
 	libvgagl.so => /usr/lib/libvgagl.so (0x77405000)
 	libgii.so.1 => /usr/lib/libgii.so.1 (0x773dc000)
 	libgg.so.1 => /usr/lib/libgg.so.1 (0x773c3000)

Note the not found libX11.so.6.

Anyway, i found the root cause and it is fixed in 
f76d6929809fd77a0f0963e1e1eca52a98a17c38.

For the fontconfig problem, i guess it might be related to inconsistency 
of your build root (uClibc 0.9.33/0.9.32?). fontconfig is detected and 
works fine here.. Btw, you might want to check that you are also using 
gcc-4.6-linaro rather than gcc-4.5-linaro.

On Sat, 7 Apr 2012, David Kuehling wrote:

>>>>>> "kyak" == kyak  <bas at bmail.ru> writes:
>
>> BTW, i'm still experiencing mplayer: can't load library 'libX11.so.6'
>> problem. With your MPlayer_r33341-5 build as well.
>
> Are you really, really sure?  Did you build mplayer yourself?  Did it
> install correctly?
>
>  md5sum MPlayer_r33341-5_xburst.ipk
>  ea849818fd5b716bd6e9fda729b2d2f8 MPlayer_r33341-5_xburst.ipk
>
> on the nanonote:
>
>  md5sum /usr/bin/mplayer
>  fc5dcf98310dfa4e52b9f051f36adbdb  /usr/bin/mplayer
>
> 'readelf -d /usr/bin/mplayer | grep NEEDED' does not show any libX11
> dependency.  Heck, I don't even have libX11 installed on my nanonote,
> but mplayer works.  Might this be a recursive library dependency thing
> (i.e. not caused by mplayer itself)?.  Mysterious.
>
> cheers,
>
> David
> -- 
> GnuPG public key: http://dvdkhlng.users.sourceforge.net/dk.gpg
> Fingerprint: B17A DC95 D293 657B 4205  D016 7DEF 5323 C174 7D40
>




More information about the discussion mailing list


interactive