Working on Iris again

Bas Wijnen wijnen at debian.org
Wed Jan 18 13:19:06 EST 2012


Hello,

Last year I wrote that I hoped to continue my work on Iris (my 
microkernel with the Ben as its first target) before the end of the 
year. I didn't entirely reach that goal, but I did start again.

Since about two weeks I have been working on it, and I have good news:

So far, I had been testing on my prototype device. It is almost 
identical to the Ben, but one difference was very important: it has a 
different (smaller, I think) SDRAM chip. This is the reason that those 
who tested Iris on a Ben never got it to work. Now I'm testing it on my 
own Ben, and it works. Hurray!

There is also bad news, but I'm sure it can be fixed. I have a new 
computer, with a new ssh key. I cannot push my changes into the git 
repository on the projects server for some reason. I tried to add my new 
key to my account, I also tried removing all other keys. But so far 
nothing worked. Can anybody help me with that?

Thanks,
Bas




More information about the discussion mailing list


interactive