I'm back! (sort of)

Jane Andreas JaneAndreas at gmx.com
Sat Jan 21 18:38:18 EST 2012


Ok I solved the problem and how have sound in Sid! I think the modules I copied were not the right version, because I downloaded the 6-15 root fs (because it said the kernel was debian userspace compatible), unzipped it and found that the 2.6.32.10 matched exactly the version that Sid wanted. I copied those modules to /lib/modules/2.6.32.10/ , ran depmod -a, made sure /etc/ modules was right, rebooted and apart from one message about there not being an snd_i2s or something like that, alsamixer did come up (looking more crude than usual) and aplay plays .wav's! 

The sound is what I would describe as a little "dirty" though. This may be aplay, or something with the modules. When I hear a sound file, it is as if there are high pitched phaser effects in the background. The openWRT image had this problem for a time, I'm not sure how it was fixed or if anyone even noticed it. Another related problem was that arecord would intermittently cut out on recordings, so when you hear the file you recorded it would jitter every few seconds. Not good for voice recording. 

Anyways I have sound and it is better than nothing! Hopefully the issues can be resolved. 

 
  ----- Original Message -----
  From: Jane Andreas
  Sent: 01/21/12 09:21 AM
  To: English Qi Hardware mailing list - support, developers, use cases and fun
  Subject: Re: I'm back! (sort of)
 
   
Ok, so insmod did not work, but I did find this out: When I type 'modprode snd-soc-qi-lb60' I get this 
[547.770000] snd_page_alloc: version magic '2.6.32.25 preempt mod_unload MIPS32_R1 32BIT ' should be 2.6.32.10 preempt mod_unload MIPS32_R1 32BIT 
WARNING: error inserting soundcore (lib/modules/2.6.32.10/soundcore.ko): Invalid module format
It says the same about snd, snd_timer, snd_pcm, snd_soc_core, snd_soc_jz4740, snd_soc_jz4740_i2s, 

So would I need specific versions?

Perhaps I need to edit the /etc/modprode.d/alsa-base.conf file? I do not see any of the above modules listed there...

Thanks for the patience, ufortunately the depmod-a and edit /etc/modules did not work smoothly and the insmod/modprobe is not so smooth either.

All that said, I actually like sid.

Xiangfu's kernel did not work, I emailed him personally but it was a kernel panic unable to mount root fs (0,0) 

Maybe I will have to make a new kernel, or will it not work with my ubi?

I know this can be solved in time.

 
  ----- Original Message -----
  From: Bas Wijnen
  Sent: 01/21/12 02:14 AM
  To: discussion at lists.en.qi-hardware.com
  Subject: Re: I'm back! (sort of)
 
   
Welcome back, Jane! I very much liked your artistic-centered (but 
nonetheless often technical) contributions, so it's really good to see 
you coming back. :-)

In case the qi kernel doesn't work, here's an answer to your questions.

On 21-01-12 02:06, Jane Andreas wrote:
> Ok, so I cannot get sound to work and it is driving me quite crazy.
> I successfully got the modules from the qi-rootfs and copied them
> to /lib/modules/2.6.32.10/ on my Ben using the uSD.

They're normally in subdirectories under there, but I'm not sure if 
that's required. The kernel/ directory is for modules built from the 
kernel source; misc/ for others. That also means the packaging system 
(if you'll ever use it) will not touch misc/, so that's a relatively 
safe place to put "custom" modules. This one, I'd install in 
/lib/modules/<version>/misc/sound/<name>.ko

> then I did depmod -a and vi /etc/modules and added the snd_whatever
> one to the empty list.

That should work on Debian. Then it should try to load it on the next 
boot. Perhaps that fails. You can see if you load it manually.

> After multiple reboots, no sound. I undertook to install alsa-base,
> alsa-utils, and all the dependencies by hand. The sound device is
> just not set up right.

Those are useful for dealing with the device, but don't help for finding it.

> I do not know how to load modules by hand, but if I did,
> I would load the snd_qi-lb60 one.

Some commands that my help you:
- lsmod: show loaded modules.
- insmod: insert module file by hand. Takes a path to a file and module
 arguments. Can be useful sometimes, but normally modprobe is better.
- modprobe: insert module. Takes a module name (not a filename!), which
 must be installed in /lib/modules/... Arguments are taken from
 /etc/modprobe.d/*, not
 from the command line.

> 'lsmod' always shows nothing so I know I am missing some step.

Try modprobe and see what error message it gives you. If the module is 
there, but you still have problems, check /dev/sndstat for what the 
kernel has available.

> Please help if you can, I hope to make a live video of the Ben
> rendering and then playing some synthesized sound.

Cool. :-D

Thanks,
Bas

_______________________________________________
Qi Hardware Discussion List
Mail to list (members only): discussion at lists.en.qi-hardware.com
Subscribe or Unsubscribe: http://lists.en.qi-hardware.com/mailman/listinfo/discussion  

_______________________________________________
Qi Hardware Discussion List
Mail to list (members only): discussion at lists.en.qi-hardware.com
Subscribe or Unsubscribe: http://lists.en.qi-hardware.com/mailman/listinfo/discussion  




More information about the discussion mailing list


interactive