opkg has wget error code 3 when installing gcc-mips via internet from software/latest:-(

Delbert Franz ddf at sonic.net
Tue Sep 11 15:24:00 EDT 2012

Hi, all,

Well, I'm back to updating my NN to the latest image.  Everything has 
gone well until I tried to: 

opkg update
opkg install gcc-mips

The download gets started well but then after about 15 seconds or so, 
a return code of 3 from wget stops the install.  This return code 
translates into a file I/O error as far as I can figure out:) I have 
installed ntpdate with no problems so I suspect some problem up the 
chain from my Nanonote.  I am using a brand new Cat 4 Transcend 32 GB 
card and I am running from that card.  I DID not update the boot 
loader so I can boot from the card slot instead of the NAND.  
Well, to get the package installed I took another route: there is 
often more than one way to get computers to do what we want:-)  
1.  I downloaded the package to my desktop.  It came down fine.  I 
have no idea why wget on the NN reported a file error.  Maybe there is 
some problem in the USB-eth system, but then I downloaded and 
installed ntpdate OK?  
2.  Then I used scp to move the file from my desktop to /root on my NN 
3. Then I executed
opkg install gcc-mips_4.6.2-1_xburst.ipk
It took a while but it appears to have installed correctly. 

In the process of doing a compile of an existing C program, I had to 
install seven perlbase-xxxx packages plus make and opkg worked 
flawlessly.  When I got all of the "missing" packages installed, the 
compile went through and the test run worked!  

So, my immediate problem is solved but the reason for the failure to 
install gcc-mips using opkg over the Internet is still a mystery.  



More information about the discussion mailing list