opkg has wget error code 3 when installing gcc-mips via internet from software/latest:-(

Jo-Philipp Wich jow at openwrt.org
Wed Sep 12 05:03:49 EDT 2012


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi.

> 1. I noticed that I had option "force_space" at the end of the
> opkg.conf file in my prior install (which resides on backup and on
> another SD card). I added that and it did no good.  I also tried
> --force_space on the command-line for opkg--did no good.

Force space has nothing to do with it. It allows you to override the
free space checking on the target filesystem, however your issue is with
the intermediate download into the /tmp/ ramdisk.

> 2. I removed var and then declared it as a stand-alone directory.
> That did no good either.  Tried various things with tmp and adding
> temp and pointing var to it.  Same result: failure of wget with
> return code 3.

Of course, because opkg (wget) uses /tmp/, not /var/ .

> 3. Using the --cache <dir name> option also failed to solve the
> problem.

The --cache option is for caching already downloaded ipk archives, it
also does not apply to your situation.

> 3. Asking opkg to only download fails also.  It cannot even do the
> simple download without breaking out with a return code of 3 from
> wget!

Yes, because it still runs out of memory in the /tmp/ ramdisk.

> 4. Finally I used wget directly, painfully typing the full URL.
> Fortunately I got it right the first time:-)  The gcc-mips package
> downloaded in about 40 secs.

Yeah, but I bet you didn't run it from within /tmp/ .


The following would probably work:

TMPDIR=/root opkg install gcc-mips


~ Jow
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iEYEARECAAYFAlBQT/UACgkQdputYINPTPOzfACgjkAs8T8rTz2eV5z+g272MH5D
YJQAn2fwZ2kzCULDYHe82GXbCR4BvCBp
=OnVE
-----END PGP SIGNATURE-----




More information about the discussion mailing list


interactive