opkg has wget error code 3 when installing gcc-mips via internet from software/latest:-(

Delbert Franz ddf at iqdotdt.com
Wed Sep 12 15:20:35 EDT 2012


On Wed, 12 Sep 2012 11:03:49 +0200
Jo-Philipp Wich <jow at openwrt.org> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hi.
> 
> > 1. I noticed that I had option "force_space" at the end of the
> > opkg.conf file in my prior install (which resides on backup and on
> > another SD card). I added that and it did no good.  I also tried
> > --force_space on the command-line for opkg--did no good.
> 
> Force space has nothing to do with it. It allows you to override the
> free space checking on the target filesystem, however your issue is with
> the intermediate download into the /tmp/ ramdisk.
> 
> > 2. I removed var and then declared it as a stand-alone directory.
> > That did no good either.  Tried various things with tmp and adding
> > temp and pointing var to it.  Same result: failure of wget with
> > return code 3.
> 
> Of course, because opkg (wget) uses /tmp/, not /var/ .
> 
> > 3. Using the --cache <dir name> option also failed to solve the
> > problem.
> 
> The --cache option is for caching already downloaded ipk archives, it
> also does not apply to your situation.
> 
> > 3. Asking opkg to only download fails also.  It cannot even do the
> > simple download without breaking out with a return code of 3 from
> > wget!
> 
> Yes, because it still runs out of memory in the /tmp/ ramdisk.
> 
> > 4. Finally I used wget directly, painfully typing the full URL.
> > Fortunately I got it right the first time:-)  The gcc-mips package
> > downloaded in about 40 secs.
> 
> Yeah, but I bet you didn't run it from within /tmp/ .
> 
I wouldn't even think of doing that:-)
> 
> The following would probably work:
> 
> TMPDIR=/root opkg install gcc-mips
> 
> 
> ~ Jow


Glad to hear from an Openwrt expert!  I searched but in the time I had 
I could not find what was being used for space!  Also the TMPDIR 
environmental variable did not appear in my searching.  

Yes, using your suggestion works.  However, I thought that using 
scarce RAM for tmp was not a "good idea" since I am running from a 
32GB micro SD card.  After a bit of trial and error, I found that 
deleting both the tmp and the var directory when the SD card was 
mounted on my desktop computer ended up with OpenWRT creating the tmp 
directory on the SD card instead of in RAM.  The install of gcc-mips 
worked fine then also.  

OK, I have now installed and removed gcc-mips enough times to last me 
for a long while:-) The NN is running fine now and I should be able to 
download and install even a bigger package than gcc-mips, if such 
exists.  Thanks to the OpenWRT team and Qi-hardware for getting such a 
rich set of software on the NanoNote--still a fascinating machine 
after two years of using it:) 

         Delbert





More information about the discussion mailing list


interactive