FYI: gcc optimization bug affecting volatile accesses

Lluís Batlle i Rossell viric at viric.name
Sat Jan 26 13:25:31 EST 2013


On Sat, Jan 26, 2013 at 01:23:32PM -0300, Werner Almesberger wrote:
> Llu?s Batlle i Rossell wrote:
> > That reminds me that any gcc below 4.7.2 has been considered 'very buggy' for
> > the job of building a mips kernel properly. mips-related bugs.
> 
> Hmm, as in 4.6.3 < 4.7.2 ? That would be scary. Our OpenWRT
> toolchain, which is what most Ben kernels are built with, uses
> 4.6.3.

Here is the source:
http://www.linux-mips.org/cgi-bin/mesg.cgi?a=linux-mips&i=20120906140843.GA17068%40linux-mips.org



More information about the discussion mailing list


interactive