Anelok: brain transplant

Werner Almesberger werner at almesberger.net
Sat Nov 1 01:31:34 UTC 2014


After reaching the conclusion that getting into the KL26 on board #2
is probably beyond my power, I dug out the good old Chip-Quik [1] and
tried to let it do its magic. I think I may have removed some 32-QFN
that way before, but I don't think I ever tried 48-QFN.

At first things didn't look too promising: the alloy just wouldn't
stay near the pads. Apparently, it had oxydized quite a bit since the
last time I used it and all the slag was getting in the way. After
vigorously pushing it from the MCU, things improved - and suddenly
the chip started to move.

This is what the board looked like immediately after removal:
http://downloads.qi-hardware.com/people/werner/anelok/tmp/brd2-btx-removal.jpg

And this is after cleaning it:
http://downloads.qi-hardware.com/people/werner/anelok/tmp/brd2-btx-cleaned.jpg

As one can see, a few components in the immediate vicinity of the MCU
had to be sacrificed in the name of progress, but besides that, the
board suffered no damage.

I then soldered a new MCU, replaced the capacitors that had perished,
and tried to raise the board on SWD:
http://downloads.qi-hardware.com/people/werner/anelok/tmp/brd2-btx-swd.jpg

Phew. I've been wanting to see that for well over a month now.

- Werner

[1] http://www.digikey.com/product-detail/en/SMD1/SMD1-ND



More information about the discussion mailing list


interactive