I had the same problem. The realtime clock is /dev/rtc0.

My Solution:
    # date -s "2010-11-07 10:50:30"
    # ln -s /dev/rtc0 /dev/rtc
    # hwclock -w --localtime

this will set the HW clock

The
most obvious solutions does not work:

        # hwclock -w --localtime --rtc=/dev/rtc0
        hwclock: open() of /dev/rtc failed, errno=2: No such file or directory.



Am 01.12.2010 22:02, schrieb Delbert Franz:
I tried to set the date/time according to the wiki page.  However, there seem
to have been some changes since it was written in March!

If I execute

hwclock -w -l 

I get "invalid option -- l"

Looking through the help list printed after the error message 
results in trying:

hwclock -w --localtime

but now it is still "unhappy":

hwclock: open() of /dev/rtc failed, errno=21:  No such file or directory.

Indeed when I go to /dev  there is no entry "rtc".  

After I set the date and time zone I get the time but it is 
lost at the next reboot if not sooner:)

Can anyone offer a howto that applies to the latest released
image?

Thanks,

   Delbert




_______________________________________________
Qi Hardware Discussion List
Mail to list (members only): discussion@lists.en.qi-hardware.com
Subscribe or Unsubscribe: http://lists.en.qi-hardware.com/mailman/listinfo/discussion